+ Antworten
Ergebnis 1 bis 4 von 4
  1. #1
    Neuer Benutzer
    Registriert seit
    12.10.2011
    Beiträge
    2

    Airplay wiedergabe verzögert zur wiedergabe am Mac

    Hallo zusammen,
    vor kurzem habe ich mir ein Apple tv gekauft und kann nun auch airplay nutzen. Wirklich ein klasse feature aber eine sache bekomme ich nicht in den griff.
    Folgendes setup:
    iMac im Arbeitszimmer, Apple TV I'm Wohnzimmer. Alles über RJ 45 im Netzwerk.
    Am iMac stelle ich die musikwiedergabe auf apple tv und auf auf den iMac. Bedeutet, ich höre Musik aus dem Wohnzimmer über Apple tv und über den iMac im Arbeitszimmer. Funktioniert soweit alles ohne Probleme bis auf eine ordentliche Latenz zwischen der Wiedergabe im wohn- und Arbeitszimmer. Über Netzwerk dauert die der stream einfach eine zeit und somit ist spielt das apple tv die Musik einige Millisekunden später ab.
    Meine Frage ist ob es eine software gibt an der man die Verzögerung ausgleichen könnte. Also die Wiedergabe am mac so verzögern könnte das sie mit dem apple tv in etwa gleich zieht. Das wäre ein plugin das die audiowiedergabe über die mac soundkarte verzögert.
    Aus der audiotechnik ist das einfach ein delay an dem man die Millisekunden zur Verzögerung einstellen kann. Gibt es auch bei Logic audio als AU plugin. aber es müsste eines sein das man im "audio-midi-setup" in den dienstprogrammen einschleifen kann.

    Eine andere Lösung wäre sich einen airport extreme zu kaufen und musikwiedergabe im Arbeitszimmer auch über das Netzwerk laufenzulassen.
    Diese Variante ist mir aber knappe 80€ zu teuer. ;-)

    Wisst ihr so in etwa was ich meine oder hat jemand von euch auch so ein problem mit delays?

    Würde mich sehr über eine Antwort freuen.

  2. #2
    Neuer Benutzer
    Registriert seit
    12.10.2011
    Beiträge
    2
    An alle die dieses problem auch haben und nicht wissen wie sie es lösen können.
    Ich habe heute zufällig eine Lösung gefunden.
    In den kommenden tagen poste ich eine kleine Grafik damit ihr mein setup sehen könnt.
    Anhand dessen werde ich erklären wie man diesen speziellen Fehler beheben kann.
    ... nur kurz ...

    es hängt mit dem full hd tv zusammen. Offensichtlich benötigt der tv eine gewisse zeit (ms) um ein Bild aufzubauen
    das er digital über hdmi bekommt. und da das Bild ja mit dem ton synchron sein muss wird der ton zum Bild soweit verzögert
    bis es passt.
    details follgen...

  3. #3
    Neuer Benutzer
    Registriert seit
    26.04.2012
    Beiträge
    1

    Lösung?

    Hallo, ich habe auch das selbe Problem, hast du jetzt eine Lösung gefunden? Wäre super, wenn du schreiben könntest.
    lg

  4. #4
    Neuer Benutzer
    Registriert seit
    08.02.2013
    Beiträge
    1
    Auch wenn es en Threadersteller sicherlich nicht mehr interessiert, da der Thread schon alt ist:
    Ich hatte das gleiche Problem. Das heißt, die Wiedergabe über iTunes sollte zum einen über Airplay auf ein Apple TV und gleichzeitig über die internen Lautsprecher des iMacs wiedergegeben werden. Dafür bietet iTunes ja schließlich die "Mehrere Lautsprecher" Option. Doch leider lagen zwischen der Wiedergabe auf dem iMac und dem Apple TV deutliche Verzögerungen. Die stärke der Verzögerung hängt sicherlich auch vom verwendeten Verstärker oder Fernseher ab, woran das Apple TV hängt. Zum Beispiel erzeugen Samsung LCD Fernseher bei der Wiedergabe über die internen Lautsprecher eine unglaubliche Latenz. Schließe ich jedoch ein Bose Sounddock 10 an meinen Samsung Fernseher an, so geht die Latenz gegen 0, da das Audio Signal nur durchgeschleift wird und nicht vom Fernseher verarbeitet wird.

    Soviel erstmal zu meinem Problem. Das Ende der ganzen Geschichte: Bei einfacher Wiedergabe über die iMac Lautsprecher zusammen mit denen die am Apple TV angeschlossen sind gibt es hörbare Latenzen. Die Stärke hängt dabei wie oben genannt vom angeschlossenen Lautsprecher am Apple TV ab. Die Lösung ist es sich unter Mac OS X eine Erweiterung namens "Soundflower" zu installieren, womit es möglich ist die Wiedergabe vom Mac zunächst einmal an ein weiteres Programm weiterzugeben. Nach der Installation von Soundflower stehen unter den Ausgabegeräten zwei weitere zur Verfügung - nämlich "Soundflower (2Ch)" und "Soundflower (16Ch)". Wenn man "Soundflower (2Ch)" als Ausgabegerät unter den Systemeinstellungen wählt wird erst einmal nichts mehr über die internen Lautsprecher des iMacs zu hören sein. Deshalb geht man in Garageband, erstellt ein neues Projekt ("Echtes Instrument" auswählen am Anfang). Unter den Einstellungen von Garageband stellt man noch das Eingangssignal auf den Soundflower und als Ausgabegerät unter Garageband wählt man wieder die internen Lautsprecher. Nun muss noch der Monitor für die aktuelle Spur eingestellt werden, damit man wieder was hört. Dies hat bei mir die Latenz zumindest ein wenig verbessert. Komplette Abhilfe schafft man dadurch, dass man in Garageband zusätzlich noch den Effekt "AU Delay" aktiviert und das Delay entsprechend nach Gehör einstellt.

    Es klingt ein wenig kompliziert. Wenn man sich aber mal ein wenig mit meiner Lösung beschäftigt ist es in meinen Augen der einzige ordentliche Weg das Latenz Problem zwischen Mac und Apple TV zu lösen.

    Und noch ein Tipp: Bei gedrückter Alt-Taste und anschließendem Klick auf das Lautsprecher-Symbol in der Menü-Leiste oben unter Mac OS X kann man das Ausgabegerät direkt ändern ohne Umweg über die Systemeinstellungen.

    Also noch mal in Kurzform:

    Soundflower installieren -> "Systemeinstellungen" - "Ton" öffnen -> "Soundflower (2Ch)" bei Ausgabe wählen -> Garageband öffnen -> Neues Projekt erstellen -> Neue Spur hinzufügen mit "Echtem Instrument" -> In der Menuleiste oben auf "Garageband - Einstellungen - Audio/MIDI - Audioausgang: Ausgang (integriert) - Audioeingang: Soundflower (2Ch)" -> Einstellungenfenster schließen -> Bei gewählter Spur rechts an der Seite in Garageband "Monitor: Ein (kein Schutz vor Rückkopplung)" -> Rechts auf den Reiter "Bearbeiten" klicken -> Den Effekt "AU Delay" hinzufügen -> Das "AU Delay" entsprechend nach Gehör einstellen. (Der Punkt muss nur ganz wenig bewegt werden! Und nur horizontal bewegen! Bei mir steht er also auf "Verzögerungszeit 0,07 Sek." und "Rückkopplung 0%")


    Ein Bild sagt mehr als tausend Worte:


    Uploaded with ImageShack.us
    Ich hoffe das hilft irgendwem weiter. Ich habe nämlich auch lange nach einer Lösung gegoogelt und nichts brauchbares gefunden.
    Geändert von hjklk (08.02.2013 um 18:02 Uhr)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein